How to install iceweasel 3.5 in Debian Lenny stable

To install iceweasel 3.5 in debian lenny you need to do the following steps:

Iceweasel 3.5 installation on debian lenny

1. Add the debian repositories testing and experimental:

# echo deb http://ftp.fr.debian.org/debian testing main > /etc/apt/sources.list.d/testing.list
# echo deb http://ftp.fr.debian.org/debian experimental main > /etc/apt/sources.list.d/experimental.list

2. Leaving the stable distribution on by default:

# echo ‘APT::Default-Release “stable”;’ > /etc/apt/apt.conf.d/default

3. Update repositories:

# aptitude update

4. Install iceweasel 3.5 units

# aptitude install -t testing libstartup-notification0 libsqlite3-0 libnss3-1d libhunspell-1.2-0 libasound2

5. Install iceweasel 3.5:

# aptitude install iceweasel/experimental

Comments (1)

  1. Umarzuki

    aptitude install -t testing libstartup-notification0 libsqlite3-0 libnss3-1d libhunspell-1.2-0 libasound2
    [… snipped …]
    Leave the following dependencies unresolved:
    fglrx-driver recommends fglrx-glx-ia32
    Score is -624

    this will totally wreak my 3d support for my laptop, any suggestion?

Leave a comment

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.