How to install Skype on Ubuntu 9.10 Karmic Koala

The two methods  below doesn’t work now. Please see http://blog.dipinkrishna.info/2009/11/how-to-download-and-install-skype-for_3060.html for a successfull installation of skype on ubuntu.
 

I have provided two methods. Please do comment which one is successful.

Follow these steps to install skype in ubuntu 9.10 (64 bit).

        First add:
            deb http://packages.medibuntu.org/ karmic free non-free
        to your /etc/apt/source.list

Now open a terminal and type:

$ sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list

Then do an update:

$ sudo apt-get update

$ sudo apt-get –yes -q –allow-unauthenticated install medibuntu-keyring
$ sudo apt-get -q update

And finally install Skype.

$ sudo apt-get install skype

Ready … now start skype with

$ skype

OR

Download the setup
32 -bit
64 -bit

Launch the Skype install .deb file (just double click it) and follow the on screen prompts.

(To start Skype  at system startup)
Go to “System -> Preferences -> Startup Application”, Click “Add” and enter the following details:

  • Name: Skype
  • Command: skype

Click “Save”
Next time you start your system Skype will auto-launch.

Enjoy using Skype in ubuntu.

Comments (37)

  1. redmistpete

    says package is only available from a different source, maybe removed due to being obsolete. Same thing happened using tweak ubuntu and other tutorials using a fresh 9.10 install. Installed from deb instead.

  2. preety

    This is what i m getting when i tried to download if any one knows please help

    /tmp/skype-ubuntu-intrepid_2.1.0.47-1_i386.deb could not be saved, because you cannot change the contents of that folder.

    Change the folder properties and try again, or try saving in a different location.ET

  3. Predrag

    First one didn’t work.. it gave me a message:

    Package skype is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Second one worked so thanks anyway..

  4. Joel Zehring

    Neither option has worked, yet. The 64-bit package results in an error message: “The package might be corrupted or you are not allowed to open the file. Check permissions of the file.”

  5. Kae

    Hi Dipin Krishna,

    It works well for me too. I used your download link for 32-bit. Oh, you saved my day as I always had audio problem with skype in ubuntu Karmic Koala and have to switch to windows whenever I want to use the skype. Now all the burdens are gone. Thank you so much for the link and suggestions. 🙂

  6. ttbek

    I was using 9.04 and upgraded it to 9.10, was the source list location changed in 9.10 and not updated if you upgrade rather than do a fresh install? If not then the directory to add the repository to is incorrect, should be /etc/apt/sources.list rather than /etc/apt/source.list

  7. svaens

    to be honest, skype 2.1 beta was working absolutely perfect (except if you allow skype to set the mic level).
    That was in Jaunty.
    Do a fresh install of Karmic, and now I see problems like the invisible menu items, and a full on crash of the system on click of the options button…
    Didn’t happen in Jaunty. I’m bound to believe it is Karmic causing the shakiness, not Skype, this time..

  8. Pelle

    I clicked the 32 bit deb file thing below and all worked flawlessly – the INSTALLATION, that is. Now, Skype itself seems to be somewhat shakey under 9.10, but it works most of the time. Mostly, things like invisible menu options, being unable to erase saved user name in the log in box, unless you mouse click to “remove” etc.

  9. Lisha

    Yay! After removing Skype from my system entirely because it stopped working after the system upgrade, I was able to reinstall it from your instructions and now it works.

    I used the first set of instructions, by the way, and everything works fine.

    Thank you!

  10. Toms Beinerts

    Tried 1st and after simply double clicking got :

    Error: Dependency is not satisfiable: libqt4-dbus (>= 4.4.3)

    What could be the problem?

    Couldnt try 2nd as not use to terminall and all that stuff

  11. Bob Coss

    I just clicked on the 32 bit deb file, and let Ubuntu do the hard work for me. Perfect!

  12. tcgrier

    I installed using the first method, that is the terminal. All went precisely as desired. Works great. Thanks!

  13. ganesh

  14. Gideon

    I,m new to ubuntu and did the first one and got the following: bt_audio_service_open: connect() failed: Connection refused (111). any idea what I did wrong and how to fix it. Thanks Gideon

  15. bark009

    I installed from the 32 bit .deb package linked on your page, worked like a charm on 9.10, and no further setup. Thanks for the page!

Leave a comment

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.